Mastercard transactions payout delay in the USA/AU
Incident Report for Lightspeed - Status Page
Resolved
All reporting discrepancies have been identified and resolved.
Posted Jun 05, 2024 - 09:27 EDT
Monitoring
We are aware of an issue impacting a small subset of our customers based in Australia (AU) and the United States (US). Some customers have reported that their payout reporting is not accurately reflecting the payouts received between May 16th and May 23rd. This has raised concerns regarding whether the full payout amounts have been received.
We want to assure you that all payouts have been correctly processed. The issue lies solely within the reporting system, which is causing payouts to appear on different days than expected. Our development teams are actively investigating the root cause of this discrepancy and working to resolve it as quickly as possible.
We will continue to monitor the situation and provide updates as more information becomes available. We appreciate your patience and understanding as we work to resolve this issue.
Posted May 28, 2024 - 03:48 EDT
Identified
Due to an issue outside our payments platform which has now been resolved, a number of Mastercard in Australia & The United States have not been automatically captured.
The affected Mastercard transactions will be settled with a delay of up to 2 days, compared to the expected settlement schedule.
Posted May 22, 2024 - 16:46 EDT
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments), Lightspeed Restaurant (K-Series) (Lightspeed Payments), and Lightspeed Restaurant (O-Series) (Lightspeed Payments).