Investigating: Australian Phone Line Issues

Incident Report for Lightspeed - Status Page

Resolved

Our Australian phone lines are now fully restored and operating normally.
Thank you again for your patience!
Posted May 19, 2026 - 23:15 EDT

Monitoring

Update: Our Australian phone lines are now back up and running. We are monitoring the system to ensure service remains stable. Thank you for your patience!
Posted May 19, 2026 - 22:58 EDT

Investigating

Notice: We are experiencing temporary issues with our main Australian phone lines. If you need assistance, please call us at +61 2 5944 3904 or connect with us instantly via Live Chat. Thank you for your patience while we fix this!
Posted May 19, 2026 - 22:51 EDT
This incident affected: Lightspeed Support (Phone Support).