Lightspeed Payments
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 15:08 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2021 - 14:47 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 16, 2021 - 14:10 EST
Investigating
We are currently investigating an issue affecting merchants using Lightspeed Payments. A dedicated team is investigating the issue.
Posted Nov 16, 2021 - 14:02 EST
This incident affected: Lightspeed Payments.