Lightspeed Support O-Series - Phone Maintenance
Scheduled for Nov 4, 16:00 - 18:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 31, 2024 - 20:33 EDT
Scheduled
Please be advised that we will be performing important maintenance to our support phone system on, 4th November, at 9:00 am AEDT. This maintenance is specific to Lightspeed O-Series.

During this time, there may be brief interruptions to phone support services.
For any urgent enquiries during this time, the fastest way to reach us will be through live chat, to do this, simply select 'Help & Support' in Back Office or POS > 'Chat to Support' or alternatively you can click the link below to open up a chat with our Support team:
https://support.kounta.com/hc/en-us?openChat=true

We expect minimal disruptions during this time. We appreciate your patience and understanding.

Thank you,
Lightspeed O-Series Support Team
Posted Oct 28, 2024 - 01:12 EDT
This scheduled maintenance affects: Lightspeed Support (Phone Support).