Lightspeed Insights (O-Series) - Missing Sales Reports

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Apr 05, 2026 - 20:08 EDT

Monitoring

A fix has been implemented, and we're monitoring the result.
Posted Apr 05, 2026 - 19:59 EDT

Identified

The issue has been identified, and a fix is being implemented.
Posted Apr 05, 2026 - 19:54 EDT

Investigating

We are currently investigating an issue where sales reports for April 5 are not appearing in Insights.

Our team is actively working to identify the root cause and restore accurate reporting as quickly as possible.
Posted Apr 05, 2026 - 17:26 EDT
This incident affected: Lightspeed Restaurant (O-Series) (Insights).