Lightspeed Retail (X-Series) - Help Centre unavailable

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Sep 26, 2023 - 06:55 EDT

Investigating

Some users may be unable to access the X-Series Help Centre. We are currently investigating, and apologise for any inconvenience this may cause.
Posted Sep 26, 2023 - 06:16 EDT
This incident affected: Lightspeed Retail (X-Series) (Help Centre).