Payment Processing with Cayan
Incident Report for Lightspeed - Status Page
Resolved
The system issue with Cayan has been resolved. For more details please refer to: https://status.cayan.com/
Posted Jun 02, 2020 - 13:26 EDT
Identified
A system degradation with Cayan has resulted in some payments not being processed. The service provider is investigating the issue. For more details please visit: https://status.cayan.com/
Posted Jun 02, 2020 - 13:04 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).