Lightspeed Retail (S-Series) - BridgePay

Incident Report for Lightspeed - Status Page

Identified

We are collaborating with BridgePay to resolve an issue that they have identified on their end.
Posted Feb 06, 2026 - 10:57 EST

Investigating

We are currently investigating an issue affecting merchants using Lightspeed Retail (S-Series) using BridgePay. A dedicated team is investigating the issue.
Posted Feb 06, 2026 - 10:39 EST
This incident affects: Lightspeed Retail (S-Series) (Payments).