Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 18, 2025 - 23:00 EST
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Wednesday, February 19 at 15:00 AEDT Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.
RESOLVED - Fixed an issue where manual bank transfer verification incorrectly redirected users to the login screen instead of the Payment Methods page.
IMPROVED - Upgraded platform infrastructure for better performance, stability, and compatibility. - Improved handling of price list updates to prevent errors.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Feb 18, 2025 - 18:15 EST
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).