Errors - Unable to process CardConnect payments

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Feb 23, 2025 - 16:57 EST

Investigating

We are currently investigating an issue where some accounts using the CardConnect Payments integration are unable to process payments. We are working with Econduit and CardConnect to investigate. Please subscribe to updates on this page for updates.
Posted Feb 22, 2025 - 12:38 EST
This incident affected: Lightspeed Retail (X-Series) (Payments).