Lightspeed Payments - Partial Payout delay for Hospitality Merchants

Incident Report for Lightspeed - Status Page

Identified

The technical issue causing the partial delays has been resolved. We're currently working to reduce the partial settlement delay for the impacted portion of your card sales transactions.
We will continue monitoring and provide a new update if required.
Thank you for your patience while we resolve this issue.
Posted Jul 08, 2025 - 10:25 EDT

Investigating

Since the 7th of July, an external technical issue has slowed the settlement of some Lightspeed Payments sales. Card transactions are processing as usual, but a portion of your card sales transactions will be deposited later than normal.
Our payments team is working closely with our banking partner to restore normal settlement speed as quickly as possible.
We understand how important fast access to funds is for your business and will keep you updated. Thank you for your patience while we resolve this issue.
Posted Jul 08, 2025 - 08:41 EDT
This incident affects: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), Lightspeed Restaurant (K-Series) (Lightspeed Payments), and Lightspeed Restaurant (O-Series) (Lightspeed Payments).