Technical Issue with Support Lines

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted May 07, 2026 - 23:14 EDT

Investigating

We are currently experiencing issues with our phone system. Please reach out to us via chat, and our team will be able to assist you.
Posted May 07, 2026 - 21:39 EDT
This incident affected: Lightspeed Support (Phone Support).