Some users have reported the inability to process payments while in the R-Series app. Transactions via web browser are working accordingly.

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted May 03, 2025 - 20:45 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 03, 2025 - 13:38 EDT

Investigating

We are currently investigating this issue.
Posted May 03, 2025 - 12:31 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS).