Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.8.0

Scheduled for May 11, 01:00 - 02:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Monday, May 11 at 15:00 AEST
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.

IMPROVED
- Improved POS reliability on unstable internet connections, the POS now recovers automatically without losing data during the disruption.
- Improved Pay-at-Table reliability to prevent duplicate charges if a payment needs to be retried due to network issues.
- Strengthened MFA security. Users must now re-verify with their current MFA method before changing or disabling it.
- Simplified Kiosk setup so branding fields now ship with sensible defaults, so you can save settings without filling everything in first.
- Improved Kiosk menus. Unavailable items now appear at the end of each category, so customers see what's available first.

RESOLVED
- Fixed an issue where new items added to a course did not print to the kitchen if a note had also been added to the order.
- Fixed an issue where POS could become stuck on the Lightspeed Payments loading screen when starting a checkout offline with no terminal connected.
- Fixed an issue where, after cancelling a bulk 'On Account' payment in POS, the payment method could not be selected again without starting the bulk payment over.
- Fixed an issue where free modifiers did not show $0.00 next to their parent item on the Customer-Facing Display.
- Fixed an issue where API-integrated payments (such as Verifone NZ and Windcave) reused the original transaction identifier when retried after a declined or cancelled result, instead of issuing a new one.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted May 06, 2026 - 02:52 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).