Newly created sales are not appearing in Sales History or updating stock adjustments.

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 08:14 EDT

Monitoring

A fix has been rolled out.
Posted Aug 04, 2026 - 05:26 EDT

Identified

Newly created sales are processing successfully and receipts can be printed, but they are not appearing in Sales History or updating stock adjustments; our team have identified the issue and rolling out a fix.
Posted Aug 04, 2026 - 05:15 EDT

Investigating

Newly created sales are processing successfully and receipts can be printed, but they are not appearing in Sales History or updating stock adjustments; our team is currently investigating the issue.
Posted Aug 04, 2026 - 05:01 EDT
This incident affected: Lightspeed Retail (X-Series) (Inventory, Sales History).