Chat Service Experiencing Delays
Incident Report for Lightspeed - Status Page
Resolved
Our chat Intercom Web Application is now fully operational. Please continue to chat with us directly from the Help Center by clicking "Contact Us" at the top of the screen.

You can also chat from within your Lightspeed Retail account. Simply click the Help button at the top right of your Retail POS store on your web browser or tap "Menu" > "Help" from your iPad.
Posted Aug 23, 2023 - 12:45 EDT
Identified
The service Lightspeed Support uses to power chat in the help desk is currently experiencing delays. Please contact us via phone for the time being while our service provider investigates
Posted Aug 23, 2023 - 12:05 EDT
This incident affected: Lightspeed Retail (X-Series) (Help Centre).