Hospitality Delay in Lightspeed Payments Payout Reporting for EU & UK Merchants

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 13:00 EST

Identified

Our team has identified a delay in the availability of Lightspeed Payments payout reporting, affecting a subset of merchants in the EU and the UK. We are actively working to resolve the issue and expect the affected reports to be available within the next few hours. We apologize for the inconvenience.
Posted Feb 25, 2025 - 10:58 EST
This incident affected: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), and Lightspeed Restaurant (K-Series) (Lightspeed Payments).