Lightspeed Restaurant(O-Series) - Insights reporting delays
Incident Report for Lightspeed - Status Page
Resolved
Our systems are back online and back to usual reporting.
Posted Nov 15, 2024 - 00:43 EST
Investigating
We are currently investigating an issue which is causing delays to Insights reporting.

Customers may notice that their reports are not displaying complete sales totals.

Our internal teams are working diligently to resolve this.

We will provide further updates here as they become available.
Posted Nov 15, 2024 - 00:16 EST
This incident affected: Lightspeed Restaurant (O-Series) (Insights).