Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 23, 2025 - 23:00 EST
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Monday, February 24 at 15:00 AEDT Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.
RESOLVED - Fixed an issue affecting in-product help centre searches. - Fixed a POS issue causing enforce order type/note functionality to not trigger in some scenarios. - Fixed a Back Office issue preventing users from disabling Lightspeed Payments surcharge confirmation.
IMPROVED - Product availability can now be managed for modifiers directly in POS, including within option sets. - Integration partners can now use the API to filter product availability more efficiently. - Increased Lightspeed Payments transaction timeout to reduce failed Pay at Table payments.
NEW - Partial refunds are now available for 3rd-party integrations that support POS-initiated refunds, starting with Bopple & Bite.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Feb 18, 2025 - 18:27 EST
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).