Retail: Payouts generated on January 6th are missing for some Canadian retail merchants
Incident Report for Lightspeed - Status Page
Resolved
We have worked with our processing partner, and all the delayed transactions are now settled.
Posted Jan 08, 2025 - 04:22 EST
Investigating
We are currently investigating this issue with our processing partner.
Posted Jan 07, 2025 - 09:07 EST
This incident affected: Lightspeed Retail (R-Series) (Integrated Payments) and Lightspeed Retail (X-Series) (Payments).