Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.13.0

Scheduled for Jul 20, 01:00 - 02:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Monday, July 20 at 15:00 AEST
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.

NEW
- New locations can now build their menu automatically with AI Menu Import, instead of adding every product by hand. Upload photos, PDFs, spreadsheets, or screenshots from your old POS, and AI extracts your products, prices and categories for you to review and edit before importing.

IMPROVED
- Improved reliability for third-party terminal payments (such as Doshii, Verifone and gift cards) by allowing more time for them to complete, so they no longer time out too early.

RESOLVED
- Fixed an issue where an integrated terminal payment could be charged but not recorded against the order after a network drop, which could lead to the order being paid twice.
- Fixed an issue where a bulk payment against a customer's account showed a "transaction has been cancelled" error even though the payment succeeded.
- Fixed an issue where the receipt panel after an account payment could freeze with an endless spinner and disabled receipt options.
- Fixed an issue where disabling the Accounts feature on one site of a multi-site company removed the Account Credit payment type for every site.
- Fixed an issue where the account payment success screen described a customer's outstanding balance unclearly.
- Fixed an issue where saving certain Back Office settings could fail with an error or silently discard changes.
- Fixed an issue where the reporting groups page could time out for businesses with very large product catalogs.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jul 14, 2026 - 20:45 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).