Merchants are unable to access their Retail accounts
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Sep 02, 2022 - 17:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2022 - 17:20 EDT
Investigating
We are currently investigating this issue.
Posted Sep 02, 2022 - 17:01 EDT
This incident affected: Lightspeed Retail (R-Series) (Retail POS, Retail API, Analytics, Integrated Payments).