R-series, C-series and L-series Lightspeed Payments users might experience a delay in payment processing
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved.
Posted Apr 13, 2024 - 14:54 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 13, 2024 - 14:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2024 - 14:23 EDT
Investigating
We are currently investigating a payment processing issue for R-series, C-series and a few select L-series merchants
Posted Apr 13, 2024 - 14:11 EDT
This incident affected: Lightspeed eCom (C-Series) (Lightspeed eCom (North America & Australia)), Lightspeed Restaurant (L-Series) (Lightspeed Payments), and Lightspeed Retail (R-Series) (Integrated Payments).