Lightspeed Payment: Payout delayed for some Canadian and US merchants
Incident Report for Lightspeed - Status Page
Resolved
The issue with Lightspeed Payments has been resolved. Payouts was sent and received on the 25th of June.
Posted Jun 27, 2024 - 11:22 EDT
Identified
Due to an issue, some customers in Canada and the US experienced a delay in payouts generated on June 24th. These payouts should arrive today, June 25th, along with the payouts for transactions processed on Monday.
Posted Jun 25, 2024 - 10:42 EDT