Chat Support Unavailable

Incident Report for Lightspeed - Status Page

Resolved

The issue has been resolved and our chat support is now available.
Posted Jan 09, 2026 - 16:33 EST

Investigating

Support chat systems are currently unavailable. We are investigating the issue. Customers can continue to reach out to us through phone or email.
Posted Jan 09, 2026 - 15:33 EST
This incident affected: Lightspeed Support (Chat Support).