Lightspeed Hospitality - K Series - Delay in Online Orders
Incident Report for Lightspeed - Status Page
Resolved
This incident has been resolved
Posted Nov 11, 2021 - 04:56 EST
Investigating
We are currently investigating the issue.
Posted Nov 11, 2021 - 04:21 EST
This incident affected: Lightspeed Restaurant K-Series (API (incl. Online Orders)).