We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, March 24 at 15:00 AEDT Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.
NEW - Multi-factor authentication (MFA) is included in this release and will be rolling out progressively. Once enabled, admins can enforce MFA from Company Settings > Security, and users can set up authentication via Email OTP or an Authenticator app from their Profile - Password expiry policies can now be configured to require password resets every 90 or 365 days - Changing your email address in Back Office now requires verification of the new address before the change takes effect
IMPROVED - The Order Type is now preserved when using Split by Product during checkout - The POS History date filter no longer allows future dates or invalid date ranges - A change docket is now printed and bump screens are updated when a modifier is added to an already sent order
RESOLVED - Fixed split payment receipts not showing the change line when the balance was paid with cash - Fixed customer links being lost when merging orders on POS - Fixed an API error that prevented integrators from fetching existing customers - Fixed the Customers page showing an unsaved changes warning when using the search field - Fixed the Shopify integration page automatically creating a payment method when viewed - Fixed course saving hanging indefinitely when no name was entered
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Mar 18, 2026 - 18:43 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).