Lightspeed Restaurant (O-Series) - Updates & New Improvements 12.12.0

Scheduled for Jul 6, 01:00 - 02:00 EDT

Scheduled

We're excited to announce another update to your POS that will bring improved efficiency and stability.

Update Time: Monday, July 6 at 15:00 AEST
Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.

IMPROVED
- Improved resilience for Doshii Smart Hospitality payments so an interrupted payment or refund can be safely resumed after a browser refresh, app restart, or network drop, without risking a duplicate charge.
- Simplified direct debit bank account setup by making manual verification (BSB and account number) available by default, so merchants whose online banking uses multi-factor authentication can complete setup without logging in to their bank.

RESOLVED
- Fixed an issue where the terminal pairing screen could show the wrong terminal image for some Lightspeed Payments device models.
- Fixed an issue where returning from a viewed invoice took you to Customer Info instead of back to Customer History.
- Fixed an issue where a delete option appeared for Site Owners on the Users list even though the deletion would always fail.

IN CASE YOU MISSED IT
Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral!
See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Jun 30, 2026 - 18:59 EDT
This scheduled maintenance affects: Lightspeed Restaurant (O-Series) (POS, Back Office).